This version is under construction, please use an official release version

Kubernetes

Supported Kubernetes Versions

Each KubeOne version supports Kubernetes versions supported by upstream at the time of the KubeOne release. You can find more details about the upstream support policy in the Version Skew Policy document.

In the following table you can find the supported Kubernetes versions for the current KubeOne version.

KubeOne 1.5 supports only Kubernetes 1.22 and newer. Clusters running Kubernetes 1.21 or older must be upgraded with an older KubeOne release according to the table below.

KubeOne version1.241.231.221.21*1.20**1.19**
v1.5---
v1.4--
v1.3--

* Kubernetes 1.21 is in the maintenance mode which means that only critical and security issues are fixed. It’s strongly recommended to upgrade to a newer Kubernetes version as soon as possible.

** Kubernetes 1.20 and 1.19 have reached End-of-Life (EOL). We strongly recommend upgrading to a supported Kubernetes release as soon as possible.

We recommend using a Kubernetes release that’s not older than one minor release than the latest Kubernetes release. For example, with 1.24 being the latest release, we recommend running at least Kubernetes 1.23.